Bootstrap4 course

Bootstrap  course

Bootstrap It is the most popular front-end component library in the world , Used to develop responsive layouts 、 Mobile devices are preferred WEB project .

Bootstrap4 Is a set for HTML、CSS and JS Open source toolset developed . Use what we offer Sass Variables and large numbers mixin、 Responsive grid system 、 Expandable prefabricated components 、 be based on jQuery Powerful plug-in system , Be able to quickly prototype your idea or build an entire app .

Who is suitable for reading this tutorial ?

As long as you have HTML and CSS Basic knowledge of , You can read this tutorial , And then develop your own website . After you finish this tutorial , You can use Bootstrap development Web Medium level of the project .

Before reading this tutorial , What you need to know :

Before you start reading this tutorial , You must have HTML 、 CSS and JavaScript Basic knowledge of . If you don't understand these concepts yet , Then I suggest you read our tutorials first :

Bootstrap4 example

Bootstrap4 example

< div class = " jumbotron text-center " > < h1 > My first Bootstrap page </ h1 > < p > Reset the browser size to see the effect ! </ p > </ div > < div class = " container " > < div class = " row " > < div class = " col-sm-4 " > < h3 > The first column </ h3 > < p > Programming tutorial </ p > < p > Learn more than technology , It's a dream !!! </ p > </ div > < div class = " col-sm-4 " > < h3 > The second column </ h3 > < p > Programming tutorial .. </ p > < p > Learn more than technology , It's a dream !!! </ p > </ div > < div class = " col-sm-4 " > < h3 > Third column </ h3 > < p > Programming tutorial .. </ p > < p > Learn more than technology , It's a dream !!! </ p > </ div > </ div > </ div >

Give it a try »

Bootstrap4 And Bootstrap3

Bootstrap4 yes Bootstrap The latest version of , And Bootstrap3 Compared with having more specific classes and turning some relevant parts into relevant components . At the same time Bootstrap.min.css The volume of is reduced 40% above .

Bootstrap4 Give up on IE8 And iOS 6 Support of , Now only support IE9 above And iOS 7 Browser version above . If you need to use the previous browser , Then please use Bootstrap3.